Licensing error -18 (No license for this product on the license server. Please contact your license administrator)

Symptoms

We are using a network license. When BricsCAD tries to connect to the server it reports No license for this product on the license server. Please contact your license administrator (error code -18).

Cause

One possible cause could be that the hostid has changed and no longer matches the hostid of the server it is running on.

Solution

Try the following steps:

  • Revoke the activation.
    Note: The revoke possibility is limited to two per key.
  • Delete the current BricsCAD.lic file (located in C:\Program Files\Bricsys\Bricsys Network License Server).
  • Run NetworkLicenseManager.exe, enter the license key and activate.
  • Once the key is activated and the LIC file is created, go to the Reprise License Server Administration web interface and perform a Reread/Restart.